Information sheet for MS Excel 2007

1. What is Excel 2007?

MS-EXCEL 2007 program provides the automated business tool you need for your data analysis, list keeping, summarizing data, and calculations as well as the presentation tools you need for reporting results. The following are basic features of Excel 2007.

Workbook: - A workbook is a Microsoft Excel 2007 file in which you work on. Workbooks contain sheets such as worksheets, chart sheets, and macro sheets.

Worksheet: - A worksheet is a large planning form made up of columns and rows. You store, manipulate, calculate, and analyze data such as numbers, text and formulas on a worksheet.

Database: - You can conveniently sort, search, and manage a large amount of information on a workbook, using standard database operations.

Chart: - A chart is a graphic presentation of worksheet. Values from worksheet cells, or data points, are displayed as bars, lines, columns, and seen in the chart.

1.1 . Starting Excel 2007

To start Microsoft Excel 2007:

    Startall program Microsoft officeMicrosoft excel 2007 

1.2. Screen Elements of Excel 2007

When you start Excel, you see the Application window, named Book1-Microsoft Excel. This is a blank Book window, named Book 1. Usually, the window is maximized and fills the whole screen. When the window is maximized, three buttons namely: minimize, restore and close buttons are displayed in the upper-right comer of the screen.

· Title bar: -It is Upper bar and contains the name of application windows, workbook name, different buttons like (save button, undo buttons, Redo button and etc) and control menu like minimize, maximize/restore and close button used to control windows.
· Microsoft Office Button: - The File menu of word 2007 has been replaced with the Microsoft Office Button. We can gate new, open, save, and etc commands on the Microsoft office button.
· Menu bar: - Contains seven menus. Menu bare contains menus lake Home, Insert, page layout, formula, data, Review and View. Each menu contains different buttons.
· Formula Bar: - This bar contains the Name box, the Cancel and Enter button, the function wizard button, and the wide bar for editing purposes.
· [bookmark: backtotop]Column Letter: A worksheet consists of 18,278 columns. Form latter “A”-“B”.
· Row number: A worksheet is made up of 10, 48,576 rows along the left margin of the worksheet.
· Cell pointer: An active cell in the worksheet is indicated by the cell pointer. The name box, on the formula bar, displays the reference of the active cell.
· Sheet tabs and Scroll buttons: These are used to display sheets and scroll through sheets.
· Status bar: this bar tells you what pages and line you are currently used on and show the total number of pages.
· View buttons: - There are three view buttons located in the lower-Right corner of the application window, used to change the way your sheet is displayed on screen. By default, excel uses Normal view.
·   Zoom slider: - You can zoom in to get a close-up view of your Worksheet or zoom out to see more of the page at a reduced size. You can also save a particular zoom setting with a document or template.
· Scroll bar: - There are two scroll bars, Vertical and Horizontal. Used to navigating inside windows
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1.3. 
Exiting Excel 2007

When you finish working with Excel, you need to exit by closing its windows.
1. Click the Close button in the upper right corner of the Excel Window
Or
2. Choose Microsoft button, click on Close command

2.  Creating and managing a workbook

2.1. Workbook and Worksheet In Microsoft Excel, a workbook is a file in which you work and store your data. Because each workbook can contain many sheets, you can organize various kinds of related information in a single file. A worksheet, also called a spreadsheet, is the primary document you use to store and manipulate data.

2.2. Creating a New Workbook
Click on Microsoft button New in the New Workbook dialog box clicks on Blank workbook Create bottom.

2.3	Moving around a Worksheet
[bookmark: _Toc281966939]The names of the sheets appear on tabs at the bottom of the workbook window. To move from sheet to sheet, click the sheets tab. When you click a tab that worksheet becomes active. By default three new worksheets are automatically created in a new workbook
To move the sheet, click and hold the mouse button on the sheet tab and drag the sheet. We can also insert new worksheet Insert new worksheet and you can rename the worksheet by right click on worksheet tab and rename.

2.4	Saving a Workbook
When you finish working with Microsoft Excel, save your document before you close it. There are two commands on the Microsoft button that you can use to save a document: Save As and Save. Use the Save As command to save your document for the first time and give it a name. Use the Save command to save changes to an existing document

To save a new/existing document as a new document:
     To save new work book: 
            Click on Microsoft buttonsave as write workbook name save.
     To save exiting work book:
            Click on Microsoft button save. 

2.5 Entering Data
You can enter constant values and formulas in a worksheet. A constant value is data that you directly enter into a cell: it can be a numeric value, including a date or time, or it can be text. A formula is a sequence of constant value, cell references, names, functions, or operators that produce a new value from existing values. Formulas always begin with an equal (=) sign.

To enter data in a cell:
    Click the cell  Type the data 

2.6. Opening an Existing Workbook
   Click on Microsoft button Open  Select the document you want to open  open

3. [bookmark: _Toc281966941]Editing a worksheet

3.1. Scrolling through a Worksheet
 Before carrying out most commands and tasks in Ms-Excel, you must first scroll through the worksheet and move to a particular area. The following is a summary of actions used to scroll through the active worksheet.

· To scroll through one row or column at a time. Click the arrow at either end of the vertical or horizontal scroll bar.
· To scroll through one window vertically or horizontally, click in the scroll bar on either side of the scroll box.
· To scroll to a general location, drag the scroll box to a position in the scroll bar corresponding to the general location you want.
· To go from first row to the last row in the worksheet press CTRL and down arrow. Similarly to go from first column to the last column press CTRL and right arrow.

3.2. Selecting Cells
Selection consists of the highlighted item on your worksheet that will be affected by the next command or action. A worksheet selection can be a cell, a range of cells, an object, or characters in the formula bar. The active cell in the selection is surrounded with a heavy border.

To select range of cells:
   Click one of the cells and drag it down, up, right or left.

To make a non adjacent selection:
 Select one row or column of cells(row(s) number) or column(s) letter and press CTRL key and select another none-adjacent row of cells (row(s) number) or column(s) letter.
· To select an entire row or column, click the row or column heading (the mouse pointer changes to right or downward pointing black arrow at the headings)
· To select many rows or columns, drag though the row or column headings
· To select the entire worksheet, click the Select All button to the left of the column headings(at the intersection of column and row heading)
· To select a single cell, just click it. This cell is called the active cell.

3.3. Moving Data
Moving cells is like physically cutting out the cells and transferring them to a new location either on the same worksheet or on a different worksheet. 

To move and replace cells with the cut and paste commands:

 Select the cell or cells you want to move select Home tabclick on Cut command select new locationfrom home tab click on past.

3.4	Copying Data
Copying cells duplicates the cells and pastes them into another location – either on the same worksheet or on a different worksheet. When you copy the cells, Ms-Excel copies the cell contents, the cell formats, and any notes attached to the cell. 

Copy only values, formulas, comments, or cell formats
Instead of copying entire cells you can copy specified contents from the cells – for example, you can copy the resulting value of a formula without copying the formula itself.

Select the cells you want to copy Select Home tab click on Copy button select new Cell  Select Home tab  form past button click on Paste Special command Click one option under Paste Ok.

3.5. Insert or delete cells, rows, and columns

You can insert blank cells above or to the left of the active cell (active cell: The selected cell in which data is entered when you begin typing. Only one cell is active at a time. The active cell is bounded by a heavy border.) On a worksheet (worksheet: The primary document that you use in Excel to store and work with data. Also called a spreadsheet. A worksheet consists of cells that are organized into columns and rows; a worksheet is always stored in a workbook.), shifting other cells in the same column down or in the same row to the right. Similarly, you can insert rows above a row and columns to the left of a column. You can also delete cells, rows, and columns. 
[bookmark: InsertCells]3.5.1. Insert blank cells on a worksheet
· Select the same number of cells as you want to insert On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert Cells  in the Insert dialog box, click the direction in which you want to shift the surrounding cells.
3.5.2. Insert blank Rows on a worksheet
· Select the same number of rows as you want to insert On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert Sheet Rows.
3.5.3. Insert blank Column on a worksheet
· Select the same number of columns as you want to insert On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert Sheet column.

3.5.4. Delete cells on a worksheet
· Select  number of cells as you want to delete On the Home tab, in the Cells group, click the arrow next to Delete, and then click Delete Calls
3.5.5. Delete Rows on a worksheet
· Select number of Rows as you want to delete On the Home tab, in the Cells group, click the arrow next to Delete, and then click Delete Sheet Rows.
3.5.6. Delete columns on a worksheet
· Select number of Columns as you want to delete On the Home tab, in the Cells group, click the arrow next to Delete, and then click Delete Sheet columns.
3.6. Freezing Worksheet Titles
You can view two areas of a worksheet and lock rows or columns in one area by freezing or splitting panes (pane: A portion of the document window bounded by and separated from other portions by vertical or horizontal bars.). When you freeze panes, you select specific rows or columns that remain visible when scrolling in the worksheet. 
To Freezing Rows
· Select the row below where you want the split to appear  On the View tab, in the Window group, click Freeze Panes, and then click the Freeze panes.
To Freezing Column
· Select the column to the right of where you want the split to appear On the View tab, in the Window group, click Freeze Panes, and then click the Freeze panes.
To unfreeze rows or column 
· On the View tab, in the Window group, click Freeze Panes, and then click the unfreeze panes.
4. Formatting worksheets
With Excel 2007 you can change the appearance of data in your worksheet by changing the font, size, style, and color of data in a cell, text box, or button. You can format numbers to designate currency amounts, percentages, decimals, scientific notation or dates and times.
4.1. Formatting the Appearance of Data
To change the format of data using font group:
· Select the cell or range of cells you want to format  To format cell entries as bold or italic, click the Bold or Italic tools on the form font group under home tab and you can also change font, size, and color.
To change the format of data using format dialog box:
· Select the cell or range of cells you want to format on the home tab from font group click on show format  dialog select font tab and the  you can  change font, size, font style and color.
4.2. Formatting Data with Number Formats
When you create a new worksheet, all cells use the general number format as a default format based on what you typed. Ms-Excel includes a variety of number, date and time formats. Except for general format, the built in formats are indicated by symbols that represent how the numbers look like when formatted.
To assign a number, date or time format:
· Select the cells you want to format  on the home tab from font group click on show format dialog  Select Number tab  In the Category box, select the type of entry you want set the Decimal places, 1000 separator, Negative numbers, Symbol, Type and Location if they are present based on the entry you selected Ok.




To format numbers using Number group:

· Select the cells you want to format  on the home tab from Number group select corresponds to the type of format you want.
4.3. Aligning Data with Cells
You can choose to align entries in the left, or center of a cell; repeat characters across an entire cell or range; wrap long entries in a single cell; justify wrapped text across a cell; rotate text; center text across columns; align text vertically in the top, bottom, and center of a cell. 
To align text using alignment button:

· Select the cell or range of cells  Click the Alignment button on the Home tab under alignment group for the alignment you want.

To align text using formatting dialog box:

· Select the cell or range of cells on the Home tab under font group click on show format dialog boxSelect alignment tab select the alignment you want.
4.4. Formatting Cells with Borders and Shades
You can shade cells or put a border around them. Border and shade setting enhances the appearance of your worksheet. You can draw a combination of horizontal and vertical lines on the left, right, top or bottom of a cell. 
To add borders using border button:

· Select the cell or cells you want to formatClick on Home tab from boarder  button  select more borderclick on Border tab select the options that you want in the Border and Style boxes Ok

To add borders using format dialog box:

· Select the cell or cells you want to formatClick on Home tab from font  group click on Border tab select the options that you want in the Border and Style boxes Ok

To shade cells with fill:
· Select the cell or cells you want to format  on Home tab from font group click on Fill tab Select one fill form the optionOk.



To shade cells with fill:

· Select the cell or cells you want to format  on Home tab from font group click on shading button Select one color form the option.

5. Creating Series
Whether you need to forecast expenses for the next year or project the expected results for a series in a scientific experiment, you can use Microsoft Office Excel to automatically generate future values that are based on existing data or to automatically generate extrapolated values that are based on linear trend or growth trend calculations.
Types of Series:
Time: A time series can include increments of days, weeks, or months that you specify, or repeating sequences such as weekdays, month names, or quarters. 
For example;
                  9:00, 10:00, 11:00…
                  Mon, Tue, Wed, Thu ……. 
                  Monday, Tuesday, Wednesday………..
                  Jan, Feb, Mar ……
                  Jan-92, Feb-93, Mar-94 ….
Linear: In a linear series, the step value, or the difference between the first and next value in the series, is added to the starting value and then added to each subsequent value. Note that values are entered in adjacent cells using the Select home tab forma Editing group click on Fill button Series.
For example;
                      1, 2, 3 …..10
                      1, 3, 5 …..22
                      100, 95, 80 …..10
 Growth: In a growth series, the starting value is multiplied by the step value to get the next value in the series. The resulting product and each subsequent product are then multiplied by the step value. Note that values are entered in adjacent cells using the Select home tab forma Editing group click on Fill button Series 
For example;
                      2, 4, 8 …………….200
                      3, 9, 27 …………...50
	   100, 50, 25 ………..1
Auto Fill: When you click the Series command, you can manually control how a linear trend or growth trend is created and then use the keyboard to fill in the values.
For example;
	             Qtr1, Qtr2, Qtr3, ………….
1st Period, 2nd Period, 3rd Period …………

To create a series by dragging:
· Select a range of two cells and enter the first two values  drag the Fill handle to the right or down Release the mouse button at the end of the series.
To create a series with the series command:
· Enter a starting value and Select the cells  Select home tab forma Editing group click on Fill button Series If you want the series to be in a row, select the Rows; if you want in column select Column  Select series Type  Enter Step value and Stop value  Ok. 

6. Entering Formula
Formulas are equations that perform calculations on values in your worksheet. A formula starts with an equal sign (=). A formula can also contain any or all of the following: functions (function: A prewritten formula that takes a value or values, performs an operation, and returns a value or values. Use functions to simplify and shorten formulas on a worksheet, especially those that perform lengthy or complex calculations.), references, operators (operator: A sign or symbol that specifies the type of calculation to perform within an expression. There are mathematical, comparison, logical, and reference operators.), and constants (constant: A value that is not calculated and, therefore, does not change. For example, the number 210, and the text "Quarterly Earnings" are constants. An expression, or a value resulting from an expression, is not a constant.).
6.1. Using Operators
Operators are used to specify the operation such as addition, subtraction, multiplication, etc. to perform on the operand in the formula. The following shows three types of operators used in Ms-Excel
Arithmetic Operators; + (Addison),*(Multiplication), / (Division),-(Subtraction (negation)) and etc.
Comparison Operators ;=( Equal), > (Greater than), < (Less than),>= (Greater than or equal to), <=(Less than or equal to), <> (Not equal to).
 References Operator; Range reference to cells
The following illustration shows the type of data you can include in a formula:
= (B2/3)*10-Sum (D2:D6)
B3 is Cell reference, 3 and 10 is Number constants, * is Multiplication operator, / is Division operator, -is Subtraction operator, = is Equal sign (beginning of formula), Sum is Function name and D2:D6 is Cell ranges
6.2. Using Worksheet Functions
The following formulas contain functions (function: A prewritten formula that takes a value or values, performs an operation, and returns a value or values. Use functions to simplify and shorten formulas on a worksheet, especially those that perform lengthy or complex calculations.).
	Example formula
	What it does

	=SUM(A:A)
	Adds all numbers in column A

	=AVERAGE(A1:B4)
	Averages all numbers in the range



To insert function on worksheet:

· Select the cell into which you want to enter the formula select formula tab  click on insert function button  Select a category list box and select your fountain category  Select the worksheet function name Ok Select arrange of cells to be calculated Ok.
6.3. Mathematical Functions
Microsoft Excel provides several mathematical functions to carry out specialized calculations quickly and easily.
6.3.1 The Sum Function
It adds all the numbers in a range of cells.
Syntax
=SUM (number 1, number 2…)

6.3.2 The Product Function
It multiplies all the numbers given as arguments and returns the product.
Syntax
=PRODUCT (number 1, number 2…)
Number 1, number 2… are 1 to 30 numbers that you want to multiply.

6.4	Statistical Functions
Ms-Excel includes various statistical functions such as Average, Max, Min, etc.
6.4.1 The Average Function
It returns the average (arithmetic mean) of the arguments
Syntax
=AVERAGE (number 1, number 2…)
Number 1, number 2… are 1 to 30 numeric arguments for which you want the average
6.4.2 The Max Function
It returns the large value in a set of values
Syntax
=MAX (number 1, number 2…)
Number 1, number 2… are 1 to 30 numeric arguments for which you want to find the maximum value.
6.4.3 The Min Function
It returns the smallest number in a set of values.
Syntax
=MIN (number 1, number 2…)
Number 1, number 2… are 1 to 30 numeric arguments for which you want to find the minimum value.
6.4.4 The Rank Function
It returns the rank of a number in a list of numbers. The rank of a number is its size relative to other values in a list. (If you were to sort the list, the rank of the number would be its position).
Syntax
=RANK (number, ref, order)
Number is the number whose rank you want to find.
Ref is an array of, or a reference to, a list of numbers. Nonnumeric values in ref are ignored.
6.5. If function
If function returns one value if a condition you specify evaluates to TRUE and another value if it evaluates to FALSE. Use If function to conduct conditional tests on values and formulas.
Syntax 
IF (logical test, value if true, value if false)
Logical_test is any value or expression that can be evaluated to TRUE or FALSE.
Value_if_true is the value that is returned if logical_test is TRUE. If logical_test is TRUE and value_if_true is omitted, TRUE is returned. Value_if_true can be another formula.
Value_if_false is the value that is returned if logical_test is FALSE. If logical_test is FALSE and value_if_false is omitted, FALSE is returned. Value_if_false can be another formula.
Examples
Suppose you want to assign letter grades to numbers referenced by the name Grade. See the following
If Grade is	Then return
Greater than 89	A
From 80 to 89	B
From 70 to 79	C
From 60 to 69	D
Less than 60	F
You can use the following nested IF function:
IF (Grade>89, “A”, IF (Grade>79, “B”, IF (Grade>69, “C”, IF (Grade>59, “D”, “F”))))

In the preceding example, the second IF statement is also the value_if_false argument to the first If statement. Similarly, the third IF statement is the value_if_false argument to the second IF statement. For example, if the first logical_test (Grade is TRUE, “A” is returned. If the first logical_test is FALSE, the second IF statement is evaluated, and so on.
7. Filtering
Filtered data displays only the rows that meet criteria (criteria: Conditions you specify to limit which records are included in the result set of a query or filter.) that you specify and hides rows that you do not want displayed. After you filter data, you can copy, find, edit, format, chart, and print the subset of filtered data without rearranging or moving it. You can also filter by more than one column. Filters are additive, which means that each additional filter is based on the current filter and further reduces the subset of data. 
7.1. Filtering data using Auto filter:
· Select any cell in the database Select data tab click on Filter button on the table Drop–down controls are displayed  Click a drop–down control of the field that you want to apply a filter to  Choose one of the items (categories) in the list.
To set custom auto filters:
· Select any cell in the database Select data tab click on Filter button  Click a drop – down control of the field you want to apply a filter to click on Custom form number filter  Specify the operator in the first drop down Specify the field value (select or type in) for comparison in the next drop down  Click one of the And/or operator buttons and specify the second comparison criteria if you want Ok.


7.2. Filtering using advanced filters
To filter a range of cells by using complex criteria (criteria: Conditions you specify to limit which records are included in the result set of a query. Use the Advanced command in the Sort & Filter group on the Data tab. The Advanced command works differently from the Filter command in several important ways.
Steps to set up criteria range:

1. In one row of the worksheet, enter the criteria (field) names
2. In rows below the criteria names, enter the criteria that you want to use for matching database records.
3. Multiple criteria can also be used in the search process. It exists in the form of AND/ OR.
Examples 1: name started with A and age gathers than 18.
	Name
	Age

	A*
	>18


Examples 2: name started with A or age gathers than 18.
	Name
	Age

	A*
	

	
	>18


To filter data using advanced filter:
· Create a criteria range Select your databaseselect Data tabclick on Advanced filter button Select database range on List range box; Select criteria range on Criteria range Select the Copy to another location  and select location for answerer Ok.

8. Pivot table

You can use pivot table to summarize and view data in different ways. The biggest challenge in the real world is to draw important information from large quantity of raw data, and pivot table in Excel is designed for this purpose. It is called pivot table because you can change its layout by pivoting the row and column headings.

To create a pivot table:

· Select your database select Insert tab  click on Pivot table button choose PivotTable chose worksheet (New worksheet or Existing worksheet)ok Drag field buttons at the right side of the dialog box to the Row filter, Column labile, values and report filter areas. 

9. Chart
Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart types that you can choose from when you create a chart. For most charts, such as column and bar charts, you can plot the data that you arrange in rows or columns on a worksheet (worksheet: The primary document that you use in Excel to store and work with data. Also called a spreadsheet.  A worksheet consists of cells that are organized into columns and rows; a worksheet is always stored in a workbook.) 
To create chart:
1. On the worksheet, arrange the data that you want to plot in a chart.
2. On the Insert tab, in the Charts group, do one of the following:
a. Click the chart type, and then click a chart subtype that you want to use. 
b. To see all available chart types, click a chart type, and then click All Chart Types to display the Insert Chart dialog box, click the arrows to scroll through all available chart types and chart subtypes, and then click the the ones that you want to use.
c. The chart is placed on the worksheet as an embedded chart  if you want to place the chart in a separate chart sheet.
d. Click the embedded chart or the chart sheet to select it and to display the chart tools. 
e. On the Design tab, in the Location group, click Move Chart button. 
f. Under Choose where you want the chart to be placed, do one of the following: 
g. To display the chart in a chart sheet, click new sheet.

10. Printing worksheet
You can print entire or partial worksheets and workbooks, one at a time, or several at once. And if the data that you want to print is in a Microsoft Office Excel table, you can print just the Excel table. You can also print a workbook to a file instead of to a printer. This is useful when you need to print the workbook on a different type of printer from the one that you originally used to print it.
10.1. Changing sheet orientation 
You can change the orientation of a worksheet page directly in the worksheet, so that you can see how your worksheet will be printed while you work, or you can select the orientation in the Printer Properties dialog box when you are ready to print.
To changing sheet orientation

· Select the worksheets for which you want to change the orientation On the Page Layout tab, in the Page Setup group, click Orientation, and then click Portrait or Landscape.

10.2. Print preview

Use print preview to see a worksheet with the page layout settings. Clicking the area of the worksheet toggles you between actual size view and full-range view. To preview a worksheet, activate it and choose.
To preview worksheet

· Select the worksheets for which you want to preview  Click on Microsoft office button print printer preview.

10.3. Print

1. Open and activate the workbook that contains the information you want to print.
2. Select your work sheet or your database your want to print.
3. Choose Microsoft office button Print. The Print dialog box appears.
4. If you want to change any aspect of the page layout, click the Properties button
5. In the Copies box, enter the number of copies if you ant more than one.
6. In the Print range group, click Page(s) and enter a range of page number in the From and To boxes if you want to print less than the entire document.
7. Click Ok to begin printing.
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